Community

Find answers, ask questions, and connect
with like-minded conquerers around the world.

Notifications
Clear all

Welcome Email for converts

  

0
Topic starter

I noticed lately that if you create a new user the welcome email process is kicked off. However, if you convert a 'contact' in to a user it does not and you've got to remember to go back in to the user and 'resend welcome email'... could this be fixed please. (As new user email' is not strictly a campaign, there's no way to track that this has happened.

Thanks

0

Hey Peter,

Check your automations. I am pretty sure a new user is a trigger to send a Welcome email and then your entire indoctrination series of emails and others. I am in the process of putting that together and will let you know what the process looks like when I am done.

Paul

0

Hi Peter! Thanks for sharing. I don't believe our system is working as intended. Welcome emails should be kicked-off whenever you convert a Contact to a User. Sounds like a bug to me.

Could you send more details to support@vendasta.com? Anything like screenshots, or even a short Loom video will help us quickly diagnose and surface with our development team.

I'll pass this on as well. Thank you again for pointing this out!

0
Topic starter

@PaulDouglas thanks for the response and i look forward to your seeing what the process looks like. This bug is from a specific use case where a 'User' is created as a 'Contact' assigned to a new Account and then converted at some point later. I think that the process you mention is correct, and works, if you create the person as a 'User' straight away.

@rmorris thanks for reaching out. I'm still new here, so don't want to recreate by starting a new account etc... As there's a confidentially issue with posting some of these details, I will send details of the particular individual for whom this happened directly to support and reference you. Hopefully support will be able to track the actions in the back end and work out what the bug is (although, I think I'd categorise as a loophole)

0

When a new user signs up from the lead widget on your website, there should also be a notification, currently not happening. Support said not possible.

0
Topic starter

Thanks @Gibbo although this note was about manual creation by a salesperson within SSC. I've just tried my website acquisition link and it correctly creates an account and a user but does not send anything to the user. Not even a welcome email... persons it's my set up at fault? I'm under the impression that it should send automatically @Support Team can you comments please?

0

Thanks Peter. We are looking into this.

0

Hey Peter & @Gibbo – please check your campaign settings in your acquisition widget (Partner Center > Marketing > Acquisition Widgets > (Edit widget)). It's likely that the widget has no campaign set. You'll want to choose a campaign that fits your model... you can decide if you want to send a snapshot right away, or give them direct access into Business App, and edit you campaign accordingly. Let me know if this resolves your issue.

0

Hi Peter, thanks for this feedback. Currently, the system only sends user welcome emails when instructed to by yourself. For example, when creating a new user, you can check/uncheck "Send Welcome Email". You can also resend this email ad hoc in the user kabob. The system currently does not send emails to clients when performing admin actions unless specifically requested. It sounds like you'd like to see this checkbox when converting contacts to users? What workflow are you currently doing to convert these users? Is it in Partner Center? Or Sales & Success Center? Thanks!